Engine throws error for having an inline function declared in the engine's source code


#1

The project is being written in Code::Blocks. I’m not sure why it is throwing this error. I made it using CMake, and I tried it in visual studio as well, and it worked. The reason I switched over was because I honestly really dislike visual studio. How could I get this to work?


#2

Please post the exact error you are getting, and ideally the code bit which is triggering it.


#3

Wow, I completely forgot to include that. Looking back, this post feels very useless. I thought I included the code it came from. I’ve made many posts online like this before, this is very uncharacteristic of me. Sorry!

The error says “error: ‘bs::platformAlignedAlloc16’ declared as an ‘inline’ variable”, and it was on line 29 of BsMemoryAllocator.h.

Thank you for helping.


#4

Is there more to that error? Can you post the exact error message as printed by the compiler? Declaring a method as inline is a normal C++ construct and not an error in itself.

Also, what compiler and compiler version does Code::Blocks use?