How to change the render path?


#1

Hi, I’ve been playing around with the examples, and I’d like to change the render path from deferred to forward clustered so that MSAA works properly. Is that possible? I’ve read about the two render paths in the documentation, but I can’t find where to set the current path. Thanks.


#2

What issues are you having with deferred MSAA?

You can only enable forward path from a shader itself. It’s used by the Transparent shader by default. You can also create your own shader as described in http://docs.bsframework.io/latest/surface_shaders.html.

Note that forward path is limited compared to deferred, as it doesn’t support shadows and a few other rendering effects.


#3

Ok, I see. I’m sometimes getting thin black lines on the edges of the cubes in the physics demo. I thought it was some kind of weird shadow bias thing, but it appears even with shadows off. When MSAA is turned off, it does not appear.


#4

If it’s on the edges of the boxes and the skybox, then it’s a know issue. I should have it resolved for the next version.